897VAG-LTE 4G Config (UK)

Cisco - Enterprise


tl;dr

Copy and paste this into your router, make sure you use an appropiate LTE Profile for your carrier.

!! Configure LTE profile
cell 0 lte profile create 1 wap.vodafone.co.uk pap wap wap ipv4 

!! Move to global configuration mode
configure terminal

!! Configure Chat -Script
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"

!! Configure Dialer and Cellular Interfaces 
interface Dialer1
 ip address negotiated
 ip nat enable
 encapsulation slip
 dialer pool 1
 dialer idle-timeout 0
 dialer string LTE
 dialer persistent
 dialer-group 1

dialer-list 1 protocol ip permit

interface Cellular0
 description WAN link to Vodafone-APN
 ip address negotiated
 encapsulation slip
 dialer in-band
 dialer pool-member 1
 dialer-group 1
 async mode interactive
 routing dynamic

!! Configure Routing
ip route 0.0.0.0 0.0.0.0 Dialer1


!! Configure VLANs and SVIs
interface Vlan1
 description Not Used
 no ip address
 ip nat enable
 shutdown

Vlan 2
 name LAN
 exit

interface Vlan2
 description LAN
 ip address 192.168.1.254 255.255.255.0
 ip nat enable

!! Configure NAT
ip access-list standard NAT_acl
 permit 192.168.1.0 0.0.0.255
ip nat source list NAT_acl interface Dialer1 overload

!! Configure DHCP
ip dhcp excluded-address 192.168.1.250 192.168.1.255

ip dhcp pool Vlan2_LAN
 network 192.168.1.0 255.255.255.0
 dns-server 10.206.64.1 10.206.64.1
 default-router 192.168.1.254

!! Configure Network Interfaces
int range GigabitEthernet0-7
 switchport mode access
 switchport access vlan 2
 no shutdown
 end

!! Save Configuration
write 
					

What's this for?

897VAG-LTE 4G Config (UK) is for when your boss rings you up and says "You know that site that's gone down... yeah can you just configure up that 4G router and take it down please". Your mouth says "Sure, no problem!", your head says "Hmmmm, how do I configure a Cisco 4G router". WARNING: if you leave a bunch of employees on this for more than a few miniutes your probably going to end up with a really big data bill (depending on your mobile phone contracts!).

This can also be useful if you have some sales guys going out demo a bit of equipment but that bit of equipment doesn't support AnyConnect but MUST connect back to the network.

Demo Enviroment

The outputs below come from the following setup...

  • Hardware: Cisco C897VAG-LTE-GA-K9
  • OS: IOS
  • Version: 15.4(3)M8
  • Carrier: Vodafone UK
  • Date: 09-08-2019

897VAG-LTE 4G Config (UK)

So what we're going to do in this ramblings is the bare minimum we need to get this router up and working. In a few weeks time, when your generic British telecommunications provider has finally got your circuit back up then you can take this guide and weave your standard IOS templates into the configuration.

The first step we need to look at is configuring an lte profile and assigning it to the celluar radio interface. Note: this is done in priviledged exec mode, not global configuration.

This is an example for O2.

cell 0 lte profile create 1 wap.vodafone.co.uk pap wap wap ipv4 

This is an example for vodafone

cell 0 lte profile create 1 mobile.o2.co.uk pap o2web password 

Once this is complete we can move into global config mode to configure the dialer and cellular interfaces. Note: if you are using differnt hardware cellular interface number might change.

conf t
interface Dialer1
 ip address negotiated
 ip nat enable
 encapsulation slip
 dialer pool 1
 dialer idle-timeout 0
 dialer string LTE
 dialer persistent
 dialer-group 1

dialer-list 1 protocol ip permit

interface Cellular0
 description WAN link to Vodafone-APN
 ip address negotiated
 encapsulation slip
 dialer in-band
 dialer pool-member 1
 dialer-group 1
 async mode interactive
 routing dynamic
					

Tell the router if you can't find it just send it out the Dialer1 interface, better known as a default route.

ip route 0.0.0.0 0.0.0.0 Dialer1

Even on the most basic configurations I just can't bring myself to leave VLAN1 active! So lets shutdown VLAN1 and configure up VLAN2.

interface Vlan1
 description Not Used
 no ip address
 ip nat enable
 shutdown

Vlan 2
 name LAN
 exit

interface Vlan2
 description LAN
 ip address 192.168.1.254 255.255.255.0
 ip nat enable
					

After that we will need a little sprinkling of NAT to translate our VLAN2 range out to the carrier.

ip access-list standard NAT_acl
 permit 192.168.1.0 0.0.0.255
ip nat source list NAT_acl interface Dialer1 overload
                                        

I don't understand it myself, but users want to be provided with an IP address. For this we can use out old friend DHCP. Normally you would want this centralised however this is just quick and dirty to get that site back up!

ip dhcp excluded-address 192.168.1.250 192.168.1.255 
  
ip dhcp pool Vlan2_LAN 
 network 192.168.1.0 
 dns-server 10.206.64.1 10.206.64.1 
 default-router 192.168.1.254 
					

Now we have our VLAN we need to configure the ports to use it. I find the best engineers are lazy so we will just use a interface range command for this.

int range GigabitEthernet0-7
 switchport mode access
 switchport access vlan 2
 no shutdown
                                        

Finally, remember to save your configuration

write

Hopefully that should now be your router up and running. The quickest and easiest check would be to plug a laptop in and make sure you can get to the wibberly wobberly web. If you can't try some of these show commands and see if they help. In the examples below they show healthy outputs from my setup.

/route
Router#show cell 0 profile 1

Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = wap.vodafone.co.uk
Authentication = PAP
Username: wap
Password: wap

 * - Default profile
Router#
Router#
Router#show ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
ATM0                       unassigned      YES unset  administratively down down
Cellular0                  unassigned      YES manual up                    up
Dialer1                    10.13.251.44    YES IPCP   up                    up
Ethernet0                  unassigned      YES unset  administratively down down
GigabitEthernet0           unassigned      YES unset  down                  down
GigabitEthernet1           unassigned      YES unset  up                    up
GigabitEthernet2           unassigned      YES unset  down                  down
GigabitEthernet3           unassigned      YES unset  down                  down
GigabitEthernet4           unassigned      YES unset  down                  down
GigabitEthernet5           unassigned      YES unset  down                  down
GigabitEthernet6           unassigned      YES unset  down                  down
GigabitEthernet7           unassigned      YES unset  down                  down
GigabitEthernet8           unassigned      YES unset  administratively down down
NVI0                       10.13.251.44    YES unset  up                    up
Vlan1                      unassigned      YES unset  administratively down down
Vlan2                      192.168.1.254   YES manual up                    up
Router#
Router#
Router#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
192.168.1.1         ffd9.78e4.7c00.04bd.    Aug 10 2019 10:04 AM    Automatic
                    c0f6.3d78.0749.6ca6.
                    0d84.a672.3423.31
Router#
Router#
Router#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/48 ms
Router#
Router#
Router#show cell 0 radio
Radio power mode = ON
LTE Rx Channel Number =  347
LTE Tx Channel Number =  18347
LTE Band =  1
LTE Bandwidth = 10 MHz
Current RSSI = -63 dBm
Current RSRP = -86  dBm
Current RSRQ = -7  dB
Current SNR = 14.0  dB
Radio Access Technology(RAT) Preference = AUTO
Radio Access Technology(RAT) Selected = LTE
Router#
Router#
Router#show cell 0 network
Current System Time = Fri Aug 9 10:31:53 2019
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Network = voda UK
Mobile Country Code (MCC) = 234
Mobile Network Code (MNC) = 15
Packet switch domain(PS) state = Attached
Registration state(EMM) = Registered
EMM Sub State = Normal Service
Tracking Area Code (TAC) = 8257
Cell ID = 129286937
Primary Scrambling Code = 65535
Router#

If everything went to plan when you pasted the stuff above into a blank router it should have looked like this.

Would you like to enter the initial configuration dialog? [yes/no]: no


Press RETURN to get started!


*Jan  2 00:00:01.023: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c800 Next reboot level = advipservices and License = advipservices
*Aug  9 10:00:55.627: c3600_scp_set_dstaddr2_idb(184)add = 80 name is Embedded-Service-Engine0
*Aug  9 10:00:55.923: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  Staed to: Initialized
*Aug  9 10:00:55.923: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Enabled Unknown WIC in slot(0/3), wic card has an unknown id of 0x7B

*Aug  9 10:01:12.607: %CTS-6-ENV_DATA_START_STATE: Environment Data Download in start statevdslmib_tbl_init: cannot create subblock.

*Aug  9 10:01:17.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface VoIP-Null0, changed state to up
*Aug  9 10:01:17.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down
*Aug  9 10:01:17.503: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
*Aug  9 10:01:17.503: %LINK-3-UPDOWN: Interface GigabitEthernet8, changed state to up
*Aug  9 10:01:17.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to down
*Aug  9 10:01:18.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet8, changed state to down
*Aug  9 10:01:20.107: %LINK-3-UPDOWN: Interface GigabitEthernet8, changed state to down
*Aug  9 10:02:02.011: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (tftp://255.255.255.255/network-confg) failed
*Aug  9 10:02:02.087: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (tftp://255.255.255.255/cisconet.cfg) failed
*Aug  9 10:02:10.691: %LINK-5-CHANGED: Interface ATM0, changed state to administratively down
*Aug  9 10:02:10.691: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down
*Aug  9 10:02:10.691: %LINK-5-CHANGED: Interface GigabitEthernet8, changed state to administratively down
*Aug  9 10:02:16.547: %LINK-3-UPDOWN: Interface Ethernet5, changed state to up
*Aug  9 10:02:17.755: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet5, changed state to up
*Aug  9 10:02:19.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0, changed state to down
*Aug  9 10:02:19.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1, changed state to down
*Aug  9 10:02:19.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2, changed state to down
*Aug  9 10:02:19.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet3, changed state to down
*Aug  9 10:02:19.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet4, changed state to down
*Aug  9 10:02:19.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet5, changed state to down
*Aug  9 10:02:19.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet6, changed state to down
*Aug  9 10:02:19.423: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7, changed state to down
*Aug  9 10:02:21.187: %SYS-5-RESTART: System restarted --
Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.4(3)M8, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2017 by Cisco Systems, Inc.
Compiled Mon 31-Jul-17 06:05 by prod_rel_team
*Aug  9 10:02:21.411:  ifs_open failed, path flash:1:/env_vars errno 2574
*Aug  9 10:02:21.527: %SYS-6-BOOTTIME: Time taken to reboot after reload =  187 seconds
*Aug  9 10:02:21.587: %ENVMON-5-48V_STATUS: -48V supply OK
*Aug  9 10:02:21.619: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF
*Aug  9 10:02:21.619: %CRYPTO-6-GDOI_ON_OFF: GDOI is OFF
*Aug  9 10:02:26.487: %SECONDCORE-5-BOOTSTAGE: ROMMON on 2nd core UP
*Aug  9 10:02:26.499: %SECONDCORE-5-BOOTSTAGE: BOOTLOADER on 2nd core UP
*Aug  9 10:02:27.435: %SECONDCORE-5-BOOTSTAGE: LINUX on 2nd core UP
Router>
Router>enable
Router#cell 0 lte profile create 1 wap.vodafone.co.uk pap wap wap ipv4
Warning: You are attempting to modify the attach profile.
Please consult the service provider before doing so.
Modem power cycle required for change to take effect.

PDP Type = IPv4
Access Point Name (APN) =
Authentication = NONE

Profile 1 already exists with above parameters. Do you want to overwrite? [confirm]

Profile 1 will be overwritten with the following values:

PDP type = IPv4
APN = wap.vodafone.co.uk
Username = wap
Password = wap
Authentication = PAP

Are you sure? [confirm]
Profile 1 NOT written to modem
Router#
*Aug  9 10:37:37.651: %CISCO800-2-MODEM_UP: Cellular0 modem is now UP.
Router#
Router#
Router#
Modem radio has been turned on
Router#
Router#
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#
Router(config)#
Router(config)#
Router(config)#!! Configure Chat -Script
Router(config)#chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
Router(config)#
Router(config)#!! Configure Dialer and Cellular Interfaces
Router(config)#interface Dialer1
Router(config-if)# ip address negotiated
Router(config-if)# ip nat enable
Router(config-if)# encapsulation slip
Router(config-if)# dialer pool 1
Router(config-if)# dialer idle-timeout 0
Router(config-if)# dialer string LTE
Router(config-if)# dialer persistent
Router(config-if)# dialer-group 1
Router(config-if)#
Router(config-if)#
Router(config-if)#
*Aug  9 10:02:47.219: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
Router(config-if)#
Router(config-if)#
Router(config-if)#dialer-list 1 protocol ip permit
Router(config)#
Router(config)#interface Cellular0
Router(config-if)# description WAN link to Vodafone-APN
Router(config-if)# ip address negotiated
Router(config-if)# encapsulation slip
Router(config-if)# dialer in-band
Router(config-if)# dialer pool-member 1
Router(config-if)# dialer-group 1
%Remove Dialer Profile Configuration first
Router(config-if)# async mode interactive
Router(config-if)# routing dynamic
Router(config-if)#
Router(config-if)#!! Configure Routing
Router(config-if)#ip route 0.0.0.0 0.0.0.0 Dialer1
Router(config)#
Router(config)#
Router(config)#
Router(config)#
Router(config)#!! Configure VLANs and SVIs
Router(config)#interface Vlan1
Router(config-if)# description Not Used
Router(config-if)# no ip address
Router(config-if)# ip nat enable
Router(config-if)# shutdown
Router(config-if)#
Router(config-if)#Vlan 2
Router(config-vlan)# name LAN
Router(config-vlan)# exit
Router(config)#
Router(config)#interface Vlan2
Router(config-if)# description LAN
Router(config-if)# ip address 192.168.1.254 255.255.255.0
Router(config-if)# ip nat enable
Router(config-if)#
Router(config-if)#
*Aug  9 10:03:23.031: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to down
*Aug  9 10:03:23.943: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively down
Router(config-if)#
Router(config-if)#
Router(config-if)#!! Configure NAT
Router(config-if)#ip access-list standard NAT_acl
Router(config-std-nacl)# permit 192.168.1.0 0.0.0.255
Router(config-std-nacl)#ip nat source list NAT_acl interface Dialer1 overload
Router(config)#
Router(config)#!! Configure DHCP
Router(config)#ip dhcp excluded-address 192.168.1.250 192.168.1.255
Router(config)#
Router(config)#ip dhcp pool Vlan2_LAN
Router(dhcp-config)# network 192.168.1.0 255.255.255.0
Router(dhcp-config)# dns-server 10.206.64.1 10.206.64.1
Router(dhcp-config)# default-router 192.168.1.254
Router(dhcp-config)#
Router(dhcp-config)#!! Configure Network Interfaces
Router(dhcp-config)#int range GigabitEthernet0-7
Router(config-if-range)# switchport mode access
Router(config-if-range)# switchport access vlan 2
Router(config-if-range)# no shutdown
Router(config-if-range)# end
Router#
Router#
*Aug  9 10:03:37.127: %SYS-5-CONFIG_I: Configured from console by console
Router#
Router#
Router#!! Save Configuration
Router#write
Building configuration...
[OK]
Router#
Router#
Router#!! Plugged In Laptop to port Gi1
Router#
%Remove Dialer Profile Configuration first
*Aug  9 10:04:09.939: %CISCO800-2-MODEM_UP: Cellular0 modem is now UP.
*Aug  9 10:04:16.207: %LINK-3-UPDOWN: Interface GigabitEthernet1, changed state to up
*Aug  9 10:04:17.207: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1, changed state to up
*Aug  9 10:04:45.223: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up
*Aug  9 10:05:29.987: %LINK-3-UPDOWN: Interface Cellular0, changed state to up
*Aug  9 10:05:29.987: %DIALER-6-BIND: Interface Ce0 bound to profile Di1
*Aug  9 10:05:30.987: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to up
Router#